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1 About Polyspace Bug Finder

Polyspace Bug Finder Product Description

1-2

Identify software bugs via static analysis

Polyspace® Bug Finder™ identifies run-time errors, concurrency issues, security
vulnerabilities, and other defects in C and C++ embedded software. Using static analysis,
including semantic analysis, Polyspace Bug Finder analyzes software control, data flow,
and interprocedural behavior. By highlighting defects as soon as they are detected, it lets
you triage and fix bugs early in the development process.

Polyspace Bug Finder checks compliance with coding rule standards such as MISRA C*,
MISRA C++, JSF++, and custom naming conventions. It generates reports consisting

of bugs found, code-rule violations, and code quality metrics, including cyclomatic
complexity. Polyspace Bug Finder can be used with the Eclipse™ IDE and integrated
into build systems.

For automatically generated code, Polyspace results can be traced back to Simulink®
models and dSPACE® TargetLink® blocks.

Support for industry standards is available through IEC Certification Kit (for ISO 26262
and IEC 61508) and DO Qualification Kit (for DO-178).

Key Features
+ Detection of run-time errors, concurrency issues, security vulnerabilities, and other
defects

+ Fast analysis of large code bases, with defects highlighted as soon as detected

+  Compliance checking for MISRA C:2004, MISRA C:2012, MISRA C++:2008, JSF++,
and custom naming conventions

*  Cyclomatic complexity and other code metrics
+ Eclipse integration
+ Traceability of code verification results to Simulink models

*  Bug detection with low false-positive results



Related Products

Related Products

In this section...

“Polyspace Code Prover” on page 1-3
“Polyspace Products for Ada” on page 1-3

Polyspace Code Prover

For information about Polyspace products that verify C/C++ code, see the following:

www.mathworks.com/products/polyspace-code-prover/

Polyspace Products for Ada
For information about Polyspace products that verify Ada code, see the following:
www.mathworks.com/products/polyspaceclientada/

www.mathworks.com/products/polyspaceserverada/
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1 About Polyspace Bug Finder

Bug Finder Workflows

This topic shows four different workflows for using the Polyspace Bug Finder product.
Use Bug Finder regularly to help catch bugs and coding rule violations as you build your

project.

Configuration
Setup

Coder

Modeler

Verifier
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Polyspace and the Software Development Cycle

Polyspace and the Software Development Cycle

In this section...

“Software Quality and Productivity” on page 1-5

“Best Practices for Verification Workflow” on page 1-6

Software Quality and Productivity

The goal of most software development teams is to maximize both quality and
productivity. However, when developing software, there are always three related
variables: cost, quality, and time.

Cost Time

Quality

Changing the requirements for one of these variables impacts the other two.

Generally, the criticality of your application determines the balance between these three
variables — your quality model. With classical testing processes, development teams
generally try to achieve their quality model by testing all modules in an application
until each meets the required quality level. Unfortunately, this process often ends before
quality requirements are met, because the available time or budget has been exhausted.

Polyspace analysis and verification allow a different process. Polyspace can support both
productivity improvement and quality improvement at the same time, although there is
always a balance between the aims of these activities.

To achieve maximum quality and productivity, however, you cannot simply perform code

analysis or verification at the end of the development process. You must integrate both
into your development process, in a way that respects time and cost restrictions.
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Best Practices for Verification Workflow

Polyspace can be used throughout the software development cycle. However, to maximize
both quality and productivity, the most efficient time to use it is early in the development
cycle.

Requirements Validation Testing

Functional Design Integration Testing

Module Testing

POLYSPACE

Code Analysis | Code Verification

Polyspace Verification in the Development Cycle

Typically, verification is conducted in two stages. First, you verify code as it is written, to
check coding rules and quickly identify any obvious defects. Once the code is stable, you
verify it again before module/unit testing, with more stringent verification and review
criteria.

Using verification early in the development cycle improves both quality and productivity,
because it allows you to find and manage defects soon after the code is written. This
saves time because each user is familiar with their own code, and can quickly determine
why the code contains defects. In addition, defects are cheaper to fix at this stage, since
they can be addressed before the code is integrated into a larger system.



Getting Help

Getting Help

In this section...

“Access Documentation” on page 1-7

“Access Contextual Help” on page 1-7

Polyspace provides documentation and contextual help in multiple locations to get you
the help you need.

Access Documentation

The full documentation is available in the Polyspace interface and its plug-ins. To access

the documentation:

+ Polyspace interface — Select Help > Help.

*  Simulink plug-in — Select Code > Polyspace > Help.
* Eclipse plug-in — Select Polyspace > Help.

* Visual Studio® add-in — select Polyspace > Help.

*  IBM" Rational® Rhapsody® plug-in — Right-click on a package. From the context
menu, select Polyspace. In the Polyspace Verification dialog, select Help.

Access Contextual Help

To access contextual help for analysis options in the Polyspace interface or a Polyspace
plug-in:

1 In the Configuration pane, hover your cursor over an analysis option.

2 In the tooltip, select More Help.
3 Look in the Contextual Help pane to see more help for that option.

To access contextual help for Polyspace results from the Polyspace interface:

1 In the Results List pane, select a Polyspace check.

f 7 Y
In the Result Details pane, select &/,
3 Look in the Contextual Help pane to see more help for that check.
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1 About Polyspace Bug Finder

To access contextual help for Simulink configuration parameters, in the configuration
window, right click on the parameter name and select What’s This.

Related Examples

“Configure Advanced Polyspace Analysis Options”

Customize Analysis Options from Eclipse

Customize Analysis Options from Visual Studio

1-8



Tutorials

*  “Find Defects from the Polyspace Environment” on page 2-2
*  “Find Defects from Simulink” on page 2-13

*  “Find Defects from the Eclipse Plugin” on page 2-20

* “Find Defects from Visual Studio” on page 2-23



2 Tutorials

Find Defects from the Polyspace Environment

In this section...

“Introduction” on page 2-2

“Set Up Files and Open Polyspace Bug Finder” on page 2-2
“Set Up Project” on page 2-3

“Configure Options” on page 2-6

“Run Analysis” on page 2-6

“Review Results” on page 2-7

“Fix Defects and Rerun Analysis” on page 2-11

Introduction

In this tutorial, you analyze a simple code example with Polyspace Bug Finder. The
tutorial follows a common workflow for using Polyspace Bug Finder:

Set up project files.

Set configuration options.

Run analysis.

Review results.

A B WON —

Fix defects and rerun analysis.

Set Up Files and Open Polyspace Bug Finder

Before you begin an analysis, set up the source files for your Polyspace project.

In this example, matlabroot refers to the installation location of MATLAB®.

In a writable location, create a folder called bf _project.

2 Copy the folder, matlabroot\polyspace\examples\cxx\Bug_Finder_Example
\sources, to the bf_project folder that you created in step 1.

3 Make sure that the sources folder is writable.

4 Open Polyspace Bug Finder. To open Bug Finder, you can use the Start menu,
desktop shortcut, or command line:

2-2



Find Defects from the Polyspace Environment

+ Start Menu: All Programs > MATLAB > ReleaseName > Polyspace Bug
Finder

ReleaseName is the installed version of Polyspace.

Desktop shortcut: if you created shortcuts during installation, from the desktop,
double-click the Polyspace Bug Finder icon.

+ DOS command line:

matlabroot\polyspace\bin\polyspace-bug-Ffinder

* UNIX® command line:

matlabroot/polyspace/bin/polyspace-bug-finder
MATLAB command line:

polyspaceBugFinder

Set Up Project

Set up a project for your source files and analysis options.

1 Select File > New Project.

2-3
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2-4

"Y' Project - Properties x

Define project

Project definition and location
Project name |bf_project
Version |1.0

Author |username

[] Use default location
Location |C:A\bf_project I

Project configuration
Use template

[] Create from build command

Back Mext Finish Cancel

In Project Name, enter bf_project as your project name.

Clear Use default location. Enter the location of the bf _project folder that you
created in step 1.

Select Use template and click Next.

Using a template can speed up the configuration process by presetting certain
analysis options.

Select GCC_C, a template for C coding projects which compile with GCC. Click
Next.

To add source files to your project, in the text box, enter the path to the
bf_project/sources folder you created (or browse to it) and click Add Sources
Folders.

Your folder path and the source files underneath are added to the project.



Find Defects from the Polyspace Environment

" Project - Link to Source Folders

Link to Source Folders

W ®|=| wof modfy Path

=3 bf_project
53
== sources
CONCUTency.c
dataflow.c
dynamicmemory.c
goodpractice.c
numerical.c
programming.c
programming2.c
resourcemanagement.c
security.c
staticrnemory.c

- 2| tainteddata.c
~[3 Include

ool ol ol ool

Select Source Folder
3 Browse

Add recursively

.7 Add Source Folders

Tips:
Manage file and folder exclusions from the right click menu.

Add a single file: browse to the file and click "Add Source Folder”. All other
files in this folder wil be excluded from the analysis.

Change location of a source folder by selecting the folder and "Modify
Path" from the toolbar.

Update folders and contents: from the Project Browser select a folder
and right click to "Refresh Source Folder”
in order to update the ktest folder content.

Back Mext Finish Cancel

You can also add include folders containing header files or other include files, but
this example does not require include files.

7 Click Finish.
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Configure Options

During the project setup, you selected the GCC_C configuration template to set the basic
analysis options. You can specify additional options for checking coding rules and specific
environment settings.

AW N —

In the Configuration window, select the Coding Rules & Code Metrics node.
To add coding rules to your analysis, select Check MISRA C:2012.

Select the Bug Finder Analysis node.

To analyze all defects, select Find Defects > all.

The target and compiler options are already set because this example uses a
configuration template during project setup. When you analyze your own code, it is
important to add all the required include files and to set the target, compiler, macro,
and environment settings analysis options. If you do not, Polyspace cannot to compile
and analyze your code. When you run a project for the first time, it is normal to get
compilation errors. For projects with your own code, look at some of the following options
to improve the compilation step:

Target & Compiler > Compiler, enables different language extensions.

Target & Compiler > Target processor type, sets the size of your data types for
the analysis.

Macros > Preprocessor definitions, a location to enter your compilation flags.

Multitasking options, for analyzing multitasking code.

Tip You can also set up your project using a build command, such as make. For more
information, see “Create Project Automatically”.

Run Analysis

1

On the toolbar, click Run.

Polyspace compiles and analyzes your project.

Follow the progress of the analysis in the OQutput Summary window.

If your project produces errors, use the troubleshooting help to diagnose the issue.



Find Defects from the Polyspace Environment

Once results are available, a button in the toolbar becomes available = Rumning (492) |

Click Running and start exploring your results as the analysis finishes.

Once the analysis finishes, the button on the toolbar changes to Completed with the
number of unloaded results.

% Completed (165)

4 Click Completed to load the remaining results.

Review Results

1

On the Results List pane, from the EI" list, select None.

You see a flat list of defects.

Select a defect.

When reviewing results, you see three panes.

2-7



2 Tutoridls

¥ Polyspace Bug Finder - bf_project C:\bf_project\Result_bf_project - O X

File Reporting Metrics Tools Window Help

& & & | [> run @ stop | Q

Result Details
All results v | T New [+ <25 @& Showing 1,332/1,332 v | | []variable trace staticmemory.c / bug_nullptr()
..of Check ~1 ¥ Information El Result Review
! : Non—?nit?al?zed wr?ble Impact: th ~ Severity | - | (Enter comment here...
I * Non-initialized variable Impact: High

- MNull pointer Impact: High Status | i |

Opening previously opened resou... Impact: Medium

[

“

Sign change integer conversion o... Impact: Medium

Standard finiclin caf Wit tcor... Smpuct: Medum tEE  uwseinc(tpemd: /% Defect: M
}

"

"

Static uncalled function Impact: Low
Tainted NULL or non-nulHerming... Impact: Low
Tainted MULL or non-nul-termina... Impact: Low

“

“

1

I * Qverlapping assignment Impact: Medium I qull pointer (Impact: High) @J

I * Ppartially accessed array Impact: Low Painter is MULL.

I * partially accessed array Impact: Low

I * pointer access out of bounds Impact: High Event File Scope Line
1 * pointer dereference with tainted ... Impact: Low 1 Assignment to local pointer x' staticmemory.c bug_nulptr() 114
1 * pointer or reference to stack vari... Impact: High Mull pointer staticmemory.c bug_nulptr() 116
I * pointer to non initialized value co... Impact: Medium

I * possible misuse of sizeof Impact: High

I = possibly unintended evaluation of... Impact: High & Configuration Result Detais

I = predictable random output from ... Impact: Medium .

I * privilege drop not verified Impact: High

I * Qualifier removed in conversion Impact: Low staticmemory.c X 4 @
I * Resource leak Impact: High : 7 . ~
I * Returned value of a sensitive fun... Impact: High void bug nullptz(vold)

I * Returned value of a sensitive fun... Impact: High £

I * Returned value of a sensitive fun... Impact: High int a = 2;

I * Sensitive data printed out Impact: Medium int* x = &a:

I = Sensitive heap memory not clear... Impact: Medium int** ptr = &x;

I * ghift of a negative value Impact: Low

I = Shift operation overflow Impact: Low W % = NULL;

1

1

1

1

1

!

!

!

!

!

!

<

v

* Tainted NULL or non-nulHtermina... Impact: Low wvoid corrected nullptr(veoid)

* Tainted division operand Impact: Low {

* Tainted modulo operand Impact: Low int a = 2;

* Tainted sign change conversion Impact: Medium int* x = ga: /* Fix: Handl

* Tainted size of variable length array Impact: Medium int#** ptr = &x;

* Tainted string format Impact: Low v v

> < >

&l Project Browser l Results List [p#] Dashboard l Source ] [Z] output Surmmary

abied 1e1S !
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Find Defects from the Polyspace Environment

Pane Name | Purpose

Results |List of results

List -
Using the =~ button, you can view the results ungrouped, by family of defect types,
or by file. In each of these views, you can sort or filter the results using the # icon in
the column headers. Right-click the column header to add or remove columns. You can
enter defect-specific comments and justifications by using the Status and Comments
columns.

Result Details about the selected result.

Details

The pane includes a description of the result and, if applicable, an event list to help
find the root cause of the result.

As you review your results, use the Result Review section to add justification
comments and a status to the result.

[ . .
If you need more help, use the “**!icon to open documentation about the result.
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Pane Name

Purpose

Source

2-10

See the selected defect in the source code.

By default, a Dashboard tab appears showing results statistics. These statistics can
provide a big picture of the defect distribution and top coding rule violations.

As you select different checks, the source files open. Results are marked in the source
code.

T T o e T T mYaT T Tt T AT T Ta VT = e TaTmYaT = eTar el aTeWaT ot Ta T oTa YT =T B = =T 1=

{
code sequence-\\ int j = 42;
M
i

int* pi:
collapsed macro if (prev == NULL) {

il
Pl = {(int*)malloc{sizecf{int)):
T

expanded macro if (pi == ({(void *)0)) return {{wvoid *)0);
1
c
defect ———— &L *pil = 4z /* Defect: Writing
return pi;

coding rule violation v .7 L _ _
int* corrected_notinitializedpointer{int* prewv)

{
int j = 42;

int* pi;

* Red, underlined code with a red exclamation point in the margin indicates a defect.
+ A purple triangle above the code indicates a coding rule violation.

Macro expansions are labeled with a blue M, which toggles between the macro and
the executed code.
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Pane Name

Purpose

The line of code with the selected defect is highlighted in dark blue. Related lines of
code are highlighted in light blue and a box outlines their line numbers.

6

On the Results List pane, right-click a column header. Add the Type column to
your results list.

On the Type column header, select the filter button # and filter out Defect
results.

On the Check column header, use the filter button + to

a Clear All.

b Select 5.3 An identifier declared in an inner scope... toview only
MISRA C rule 5.3 results.

Select the coding rule violation in the dataflow.c file. To see the file column, you
can scroll right in the Results List window.

This specific violation of MISRA C rule 5.3 must be fixed eventually, but for now, we
want to add a comment the result.
In the Results Details pane:

a Set Severity to Low.
b Set Status to Fix.
¢ In Comments, enter Change identifier.

Select File > Save to save your annotations.

Fix Defects and Rerun Analysis

AW N —

Clear the filter from the Check column.

On the Type column, change the filter to see only Defect results.

On the File column, add a filter to show only results in programming.c.
In the programming.c file, find the Invalid use of == operator defect.

As the Result Details state, the error is an incorrect use of ==. In this example, the
== in the for-loop is supposed to be an =.

Right-click the red-underlined code on the Source pane and select Open Editor.

2-11
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2-12

10

11

The Code Editor pane appears with the source code file, programming.c, opened
to the == defect.

At line 96 where the invalid operator was found, change the == to =:

for (J = 5; J < (SI1ZE4+5); j++) {

Save programming - CLE-| and rerun [_f’ the analysis.

Once the analysis is complete, open your results and clear the filter from the Type
and File columns.

Double-click the blue title bar of the Results List window. The pane maximizes to fit
the Polyspace window.

Find the coding rule that you annotated earlier (5.3 An identifier declared
in an inner scope...). Polyspace imports your previous comments into the new
results. You can see the severity, status, and comment that you entered are imported
to the new results.

Look for the Invalid use of == operator defect in the programming.c file. The
result does not appear in the Results List because you fixed the bug!

To return the Results List window to normal size, double-click the title bar.
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Find Defects from Simulink

In this section...

“Introduction” on page 2-13
“Open Model and Generate Code” on page 2-13
“Set Polyspace Options and Run Analysis” on page 2-13

“Review Results” on page 2-14

“Fix Model and Rerun Analysis” on page 2-17

Introduction

In this tutorial, you analyze the generated code from a Simulink model using Polyspace
Bug Finder. To do this analysis, the tutorial follows a common workflow for model-
generated code analysis:

Create model.
Generate code.
Select Polyspace configuration options.

Run analysis.

O b WN —

Review results.

Open Model and Generate Code
1 In MATLAB, open the Polyspace example model.

psdemo_model_link_sl

2 Right-click the controller subsystem and select C/C++ Code > Build This
Subsystem to generate code for the controller subsystem.

3 In the Build code for Subsystem: controller window, select Build.

Note: The code generation options for this model are already set. For configuring
your model, see “Recommended Model Settings for Code Analysis”.

Set Polyspace Options and Run Analysis

1  After the model has finished building, select Code > Polyspace > Options.

2-13
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In the Configuration Parameters window that opens, on the Polyspace pane, set the
following options.

Option Value

Product mode Bug Finder

Project configuration and MISRA C 2012
AGC checking

Settings from

These options set the type of Polyspace analysis and configure the analysis to check
for bugs and MISRA C coding rule violations.

Apply your changes and close the Configuration Parameters window.
Right-click the controller subsystem and select Polyspace > Verify Code
Generated For > Selected Subsystem.

You can follow the progress of the analysis in the Command Window.

Review Results

After the analysis has finished, open and review the results in the Polyspace interface.

1 Right-click the controller subsystem and select Polyspace > Open Results.
2 Select the Integer division by zero result.
In Bug Finder, you see three windows:
Pane Name | Purpose
Results |List of results
List
Using the =~ button, you can view the results ungrouped, by family of defect types,
or by file. In each of these views, you can sort or filter the results using the # icon in
the column headers. Right-click the column header to add or remove columns. You can
enter defect-specific comments and justifications by using the Status and Comments
columns.
Result Details about the selected result.
Details

2-14

The pane includes a description of the result and, if applicable, an event list to help
find the root cause of the result.
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As you review your results, use the Result Review section to add justification
comments and a status to the result.

2. .
If you need more help, use the icon to open documentation about the result.
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Pane Name

Purpose

Source

2-16

See the selected defect in the source code.

By default, a Dashboard tab appears showing results statistics. These statistics can
provide a big picture of the defect distribution and top coding rule violations.

As you select different checks, the source files open. Results are marked in the source
code.

T T o e T T mYaT T Tt T AT T Ta VT = e TaTmYaT = eTar el aTeWaT ot Ta T oTa YT =T B = =T 1=

{
code sequence-\\ int j = 42;
M
i

int* pi:
collapsed macro if (prev == NULL) {

il
Pl = {(int*)malloc{sizecf{int)):
T

expanded macro if (pi == ({(void *)0)) return {{wvoid *)0);
1
c
defect ———— &L *pil = 4z /* Defect: Writing
return pi;

coding rule violation v .7 L _ _
int* corrected_notinitializedpointer{int* prewv)

{
int j = 42;

int* pi;

* Red, underlined code with a red exclamation point in the margin indicates a defect.
+ A purple triangle above the code indicates a coding rule violation.

Macro expansions are labeled with a blue M, which toggles between the macro and
the executed code.
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Pane Name

Purpose

The line of code with the selected defect is highlighted in dark blue. Related lines of
code are highlighted in light blue and a box outlines their line numbers.

Look at the Result Details pane. The descriptions states that the divisor,
controller_B.Cumulatedangle, may be zero.

Hover over the red division symbol, 7/, in the Integer division by zero line.
The tooltip tells you the ranges of the two operands and the result. The range of
the divisor (right operand) contains zero. The possibility of this value causes the
Integer division by zero defect.

In the Result Details pane, starting at the bottom of the list of events, select the
events to see where the value of controller_B.Cumulatedangle is assigned.

The second event shows that controller_B.Cumulatedangle is assigned the
value of tmp. The if/else statement that assigns tmp a value does not check if tmp is
zero.

Fix Model and Rerun Analysis

This section shows you how to fix the Integer division by zero defect you
examined before. As you learned from reviewing the code, the defect occurs because
controller_B.Cumulatedangle, the divisor, can be zero.

1

To find where this division takes place in the model, in the Source pane above the
Integer division by zero defect, click <S4>/1imit_ratio.

The limit_ratio block associated with this line of code is highlighted in the Simulink
model in blue.
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psdemo_model_link_sl 3 controller » Reduced precision k

oy WhereAreTheEmors 9 - threchold
CGr——m out1
nputSgnal thi=chold
In2
relative threshold
' 18 Q intie
= M L
N -+
int1g
In1 Q >+
ntig
{2 } > Cumulated angle
In2
LUTramp

limit_ratio

Merge

uint18

Castd

nti6

This link between the model and the generated code helps you identify the parts of
your model that are causing defect. That way you can fix the defects in the model

rather than the code.

2 In between the highlighted limit_ratio block and the Cumulated angle block, add a

Switch block.
3 Change the criteria property of the Switch tou2 ~= 0.

4  Connect the Switch block to the Cumulated angle signal and the constant 1 block

so that the Cumulated angle is compared to zero. If the angle is not zero, the

Cumulated angle is output. If the signal is equal to zero, the 1 is output.

The Reduced precision subsystem should look like the following:

2-18
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psdemu_model_\ink_sl » conh'ol\er » Reduced predsion

inti 8 WhereAreTheEnors 0 g threshoid

(G r———mn Outt
i thfzshotl
relative threshold
ot ntie
1 ? +
fintie
L +
e M L w_no\ e e
Q inie

Cumuisied angle —a Casts
Sw

uint16

strategy

LUT ramp

limit_ratio

Regenerate the code for the controller subsystem. You might need to save a new
version of the model.

Rerun the Polyspace analysis for the controller subsystem.

Open the results.

The new results no longer contain an Integer division by zero defect because
you fixed the model and by extension the generated code.
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Find Defects from the Eclipse Plugin

In this section...

“Introduction” on page 2-20

“Run Analysis and Review Results” on page 2-20

Introduction

Before starting a code analysis, you must install the Polyspace Bug Finder plugin for
Eclipse. For instructions see, “Install Polyspace Plugin for Eclipse IDE” on page 4-3.

In this tutorial, you analyze a simple code example using Polyspace Bug Finder in
Eclipse. A common workflow for code analysis with Polyspace Bug Finder is:

Set up project and configuration options.

Run analysis.

Review results and fix defects.

AW N —

Rerun analysis.

This tutorial follows a shortened version of this workflow. For details, see “Eclipse
Environment”.

Run Analysis and Review Results
1  After you install the plugin, a Polyspace menu appears on the toolbar. Select

Polyspace > Show View > Show Polyspace Run view to view the Polyspace
Run - Bug Finder pane.
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File Edit Source Refactor Mavigate Search  Project Bun [Poﬁ,rspace] Window Help

Tmil ERREHD A Ne=S e e NP Ctrl+R
[ Stop

% Configure Project

[ Project Explorer 53 = <fp| ¢ ~ = 0
4 =5 My Project
s [t Includes

» = polyspace
» g source file.c

Reload Results

Close Results

[¥] Open Resultsin PVE

Show View *
(2) Help
rer ESLAS PL' = |urTLJ.EI|I' K
11 func2(ptr) ;
12
13
2 Inthe Polyspace Run - Bug Finder pane, select Bug Finder under the product
icon.
E-_\ Problems 4= Tasks [l Console £ Properties ¥ Polyspace Run 52 o [> 0= O
Polyspace Bug Finder @  Bug Finder

Output Summary | Full Log Code Prover

Search 4} {} |

Type Message File Line Col

Detail

By selecting Bug Finder, Polyspace uses Bug Finder configuration options and
analysis to analyze your Eclipse project.

3 Inthe Eclipse Project Explorer pane, right-click a project with C or C++ files and
from the context menu select Run Polyspace Bug Finder.
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2-22

Note: You can also right-click a single source file to analyze only that file.

As the analysis runs, you can follow the progress in the Qutput Summary tab of
the Polyspace Run - Bug Finder pane. If your code has compilation errors that
prevent analysis, they appear in the same tab.

After the analysis finishes, the results appear on the Results List - Bug Finder
pane. As you select different defects, the source code switches to that line number
and details about the defect appear in the Result Details pane.

After fixing bugs or adding code, you can rerun the analysis from the Results List

window by clicking the rerun button, > .
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Find Defects from Visual Studio

In this section...

“Introduction” on page 2-23
“Run Analysis in Visual Studio” on page 2-23
“Open and Review Results” on page 2-26

Introduction

Before starting a code analysis, you must install the Polyspace Bug Finder plugin for
Visual Studio. For instructions see, “Install Polyspace Add-In for Visual Studio” on page
4-6.

In this tutorial, you analyze a simple code example using Polyspace Bug Finder in Visual
Studio. A common workflow for code analysis with Polyspace Bug Finder is:

Set up project and configuration options.

Run analysis.

Review results and fix defects.

B W N —

Rerun analysis.

This tutorial follows a shortened version of this workflow.

Run Analysis in Visual Studio

1  After you install the plugin, a Polyspace menu appears on the toolbar. Select
Polyspace > Display Polyspace Log to view the Polyspace Log window.

Polyspace | Tools Test Window H
* [¥| Polyspace
-'3 Open Job Menitor

B Display PolyspaceLog

(2) Help

(1) About

2 In the Visual Studio Solution Explorer view, select one or more files that you want
to analyze.

3 Right-click the selection, and select Polyspace Verification.
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The Easy Settings dialog box opens.

Easy Settings [ -5 e

Settings

Precision [02

Verification Level [Soﬂware Safety Analysis level 2

Results folder |C:\Pch.'5paca_Resuh5

Verification Mode Settings
@ Generate main automatically () Use existing main

Class

Class analyzer calls [unused

Class only [l

Main generator write variables [Lll"lil"lﬂ

Main generator calls [unused

Function called before main |

Scope

C:'msvs_polyspace'\main.cpp +
C:'mevs_polyspace'sanalogic.cpp

C:‘msvs_polyspace'tasking.cpp
C:mevs_polyspace'tasks cpp
C:msvs_polyspace'zz_utils.cpp

[ use Code Prover analysis

4 In the Easy Settings dialog box, you can specify the following options for your
analyses:

*  Under Settings, configure the following:

+ Precision — Precision of analysis
+ Passes — Level of analysis

Results folder — Location where software stores analysis results
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Under Verification Mode Settings, configure the following:

+ Generate main — Polyspace generates a main or Use existing — Polyspace
uses an existing main

+ Class — Name of class to analyze

+ Class analyzer calls — Functions called by generated main

+ Class only — Analysis of class contents only

* Main generator write — Type of initialization for global variables

* Main generator calls — Functions (not in a class) called by generated main

+ Function called before main — Function called before the generated main

Under Scope, you can modify the list of files and C++ classes to analyze.

Select ¥ . The Select Files and Classes dialog box opens.

i

[ Select Files and Classes =[5 [5]
Classes | Files

| Class | Scope
Basze Base
Shnalogic Shnalogic
Sensor Sensar
StackMode TStack<T=:5StackMode
Task Task
TStack TStack«T=
TStackterator TStack terator< T
| tils I tilz

i) (oo

b Select the classes that you want to analyze, then click Add.
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In the Configuration window of the Polyspace interface, you configure options that
you cannot set in the Easy Settings dialog box. See “Customize Polyspace Options”.

For information on how to choose your options, see “Analysis Options”.
Make sure the Use Code Prover analysis check box is not selected.
Click Start to start the analysis.

Once you start the software, you can follow its progress in the Polyspace Log view.

Compilation errors are highlighted as links. Click a link to display the file and line
that produced the error.

Polyspace Log v 1 X
% M ¥

""" WENICALT FUSL Aldlysis auie

-

ol
K©)

Ending at: Thu Oct 16 15:35:42 2014

User time for post-anatysis: 00:00:00.79 (0.79real, 0.7%u + 0s (0.03gc))
User time for polyspace-code-prover-nodesktop: 00:00:16.81 (16.81real, 16.81u + 0= (0.34gc)) | 4
.

The code verffication completed successfully
& Polyspace Log [ = Mol

If the analysis is being carried out on a server, use the Polyspace Job Monitor to
follow the progress of the analysis.

Open and Review Results

2

. hi
After your analysis completes, select |

In Polyspace, review your results.

For information on reviewing and understanding Polyspace Bug Finder results, see
“View Results”.
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Find Defects from IBM Rational Rhapsody

3-2

In this section...

“Code Analysis Approach” on page 3-2

“Adding Polyspace Profile to Model” on page 3-3
“Accessing Polyspace Features” on page 3-5
“Configuring Analysis Options” on page 3-7

“Running an Analysis” on page 3-8

“Monitoring an Analysis” on page 3-10

“Viewing Polyspace Results” on page 3-11

“Locating Faulty Code in Rhapsody Model” on page 3-12
“Template Configuration Files” on page 3-13

Code Analysis Approach

In a collaborative Model-Driven Development (MDD) environment, software run-time
errors can be produced by either design issues in the model or faulty handwritten code.
You may be able to detect the flaws using code reviews and intensive testing. However,
these techniques are time-consuming and expensive.

With Polyspace Bug Finder, you can analyze C/C++code that you generate from your
IBM Rational Rhapsody model. As a result, you can find defects and automatically
identify model flaws quickly and early during the design process.

For information about installing and using IBM Rational Rhapsody, go to
www-01.1bm.com/software/awdtools/rhapsody/.

The approach for using Polyspace Bug Finder within the IBM Rational Rhapsody MDD
environment is:

+ Integrate the Polyspace add-in with your Rhapsody project. See “Adding Polyspace
Profile to Model” on page 3-3.

+ If required, specify Polyspace configuration options in the Polyspace environment. See
“Configuring Analysis Options” on page 3-7.

+ Specify the include path to your operating system (environment) header files and
run an analysis. See “Running an Analysis” on page 3-8 and “Monitoring an
Analysis” on page 3-10.


http://www-01.ibm.com/software/awdtools/rhapsody/
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*  View results, analyze errors, and locate faulty code within model. See “Viewing
Polyspace Results” on page 3-11and “Locating Faulty Code in Rhapsody Model” on
page 3-12.

Adding Polyspace Profile to Model

Before you try to access Polyspace features, you must add the Polyspace profile to your
model. Polyspace is supported for Rhapsody 7.6, 8.0, and 8.1.

Note: You cannot submit local batch verifications with Polyspace for Rhapsody (for
example, using local Parallel Computing Toolbox™ workers). If you want to submit
local batch verifications, use the Polyspace environment or the MATLAB command,
polyspaceBugFinder.

1 In the Rhapsody editor, select File > Add Profile to Model. The Add Profile to
Model dialog box opens.

2 Navigate to the folder matlabroot\polyspace\plugin\rhapsody\profiles
\Polyspace.

3  Select the file Polyspace.sbs. Then click Open.

Now, if you right-click a package or file, you see Polyspace features in the context menu.
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hational Rhapsod

File Edit View Code Layout Teols Window Help_
pEasme e oo Mamn|x ]
|41 ¢ @ % [ConpteSysen ~ [osfaicarty

)iz e o | T A ML A S| =D E
q
Entire Model View k4 ‘

Bf_—l psdemes_uml_link_airbag
(-] Components

BD Packages
)i

E External Features...
B9 Predefined]
-5 Predefined] Add New »
{3 Profiles
{1 Settings Cut Cirl+X
(-] Use Case Diagr Copy Ctrl+C

Paste Ctrl+V
Delete from Model Del
Set Sterectype 4
Change te 4
Refactor 3
Edit Type Order

Mavigate 4
Unit 3
Configuration Management 4

Check
Generate
Edit Code
Reoundtrip

Format...

Polyspace Verfication
Polyspace Help

Stop Polyspace Verification
Polyspace Spooler

Edit Configuration

View Results

Polyspace Verification is also available from the Tools menu.
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Note: The 64-bit version of the Polyspace product does not support the Back to model
command with the 32-bit IBM Rational Rhapsody product.

To install the 32-bit Polyspace version, from a DOS command window, run the following
command:

DVD\Installer32bits\Windows\Diskl\InstData\VM\Polyspace.exe

Accessing Polyspace Features

To access Polyspace features in the Rhapsody editor:

1

Open the model that you want to analyze. For example,
psdemos_uml_link _airbag.rpyinmatlabroot/polyspace/plugin/
rhapsody/psdemos. Where matlabroot is the location of the Polyspace
installation folder.

@ IBM Rational Rhapsody Developer for C++ - psdemos_uml_link_airbag.rpy
File Edit View Code Layout Tools Window Help

L& E| |& % | Gy B[ X

B8 ¢ [CompleteSystem ~ | DefauitCortig

| | | )
]

Entire Model View =

f& ) psdemos_uml_link_airbag
+{:| Components
+{:| Packages
+{:| Profiles
+{:| Settings
+-{_] Use Case Diagrams

In the Entire Model View, expand the Packages node.
Right-click a package, for example, AirBagFiles.
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File Edit View Code Layout Tools Window Help

DSds e @ oo |MbE] x|
[l @ ! it ¢ [Compltesystem [ DsfautCortg
fm o MulE®=s8® - |[re
Entire Model View  ~ + 1 ‘
Bf_—l psdemaos_uml_link_airbag
-] Components
=1 Packages
£ External Features...
B Predefined
#-E9 Predefined] Add New »
Profiles
{10 Settings Cut Ctrl+X
- Use Case Diagr Copy CtrleC
Paste Ctrl+V
Delete from Model Del
Set Stereotype 4
Change to 4
Refactor 3
Edit Type Order
Navigate ’
Unit 3
Configuration Management 4
Check
Generate
Edit Code
Reundtrip
Format...
Polyspace Verification
Pelyspace Help
Stop Polyspace Verification
Pelyspace Spooler
Edit Configuration
View Results

You see the following Polyspace functions in the context menu:
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Polyspace Verification — Start analysis. See “Running an Analysis” on page
3-8.

+ Polyspace Help — Open help.

Stop Polyspace Verification — Stop client-based analysis. See “Running an
Analysis” on page 3-8.

Polyspace Job Monitor — Open Polyspace Job Monitor. See “Monitoring an
Analysis” on page 3-10.

Edit Configuration — Specify analysis options. See “Configuring Analysis
Options” on page 3-7.

View Results — View Bug Finder results. See “Viewing Polyspace Results” on
page 3-11.

Note: You must add the Polyspace profile to your model before you try to access
Polyspace functions. See “Adding Polyspace Profile to Model” on page 3-3.

Configuring Analysis Options
To specify options for your analysis:

1

In the Entire Model View, right-click a package or class, for example,
AirbagControl.

Entire Model View =

EI'D pedemes uml link airbag
EID Components

El§:| AirBagSystem
w-3 Configurations
E CompleteSystem
[—]D Packages

El& AirBagsFiles
?,%’ Actors

---‘;] Dependencies
\ Events

Ly Links

D Object Medel Diagrams

Bﬁ Objects

86\ 02y Contol
L CrashSensor
- " SRSControl
'"0 Types
- Use Cases
EJ---& External
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2 From the context menu, select Edit Configuration. The Configuration pane of
the Polyspace environment opens.

-~ Polyspace C\Polyspace\Polyspace_Common'\PolySpace... EI@
File Edit Window Help

Lﬂ ﬁ|5earch: - ﬁ'|

2

Name Value Internal name
Analysis options

[=--General

----- Send to Polyspace Server &= -server
----- Add to results repository -add-to-resultsrepository
----- Keep all preliminary results files 0 +eep-all-files
----- Calculate code metrics = -code-metrics
[=1-Report Generation 0
i-Report template name Developer -report-template
i.Qutput format RTF -repor t-output-format

[+ Target/Compilation

[#--Compliance with standards
[#--Polyspace inner settings
[
[

- PredsionScaling
- Multitasking

3 Select options for your analysis. In particular, you must specify the following:

+ Compiler (-compiler)

Include Folders (- 1) — Path to your operating system (environment) header
files.

4 To save your options, in the top left corner, click the disk button.

For information on how to choose your options, see “Analysis Options”.

Running an Analysis
To start an analysis:

1 In the Rhapsody editor, select Tools > Polyspace Verification. The software opens
the Polyspace Verification dialog box.
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- Polyspace Verification @
o o Polyspace UML Link
OLYSPACE bomaodly-

Coda Varificatlen Producs 2 s e ()
Results folder:  |PolyspaceResults\SRSControl_C
Verification mode: @ Class () Expert (Main)

Class to verify: :SRSControl_C -

Verify with (highlight dasses):

CrashSensor_C
AirbagControl_C

Send to Polyspace server

Run ] [ cancel |

Note: Before starting an analysis, make sure that the generated code for the model is
up to date.

In the Results folder field, specify a location for your analysis results.

Select the Verification mode:

+ Class — Select a specific class from the Class to verify drop-down list. In
addition, under Verify with (highlight classes), you can select other classes
from the displayed list, for example, CrashSensor_C.

+ Expert — The software analyzes code according to the Generate a main (-
main-generator) options that you specify.

If you want to run the analysis on your Polyspace server, select Send to Polyspace
server.

Note: You cannot submit local batch analyses with Polyspace for Rhapsody (for
example, using local Parallel Computing Toolbox workers). If you want to submit
local batch analyses, use the Polyspace environment or the MATLAB command,
polyspaceBugFinder.

Click Run. You see analysis messages on the Log tab of the Rhapsody editor.
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Z|pun Verification

Lrgument
Argqument
Argument
Argument
Lrgument
Lrgument
Argqument
Argument
Argument

If your analysis is client-based, you can stop your analysis. In the Entire Model View,

0:

1
3
4:
5.
[
7

'-rtebase-dir’

'C:\Polyapace\PolyspaceForCandCPP R2011b\Verifier\bin’

'-gilent’'

'-call-from-ide’

'rhapsody"

_oEg!

'C:\Polyspaceh Polyspace_Common\PolySpaceUMLLink\psdemos'\CompleteSyatem C++.cig’
'-gpticna-to-overwrite!

"C:\Polyspaceh Folyspace Common'\FPolySpaceUMLLink\psdemos\ps_automatic_options.txt'

<polyspace-cpp R2011bk FID19320 PGID19320>

Polyspace verification of psdemos_uml_link airbag project.
Starting at 06/23/2011, 1&8h07.

Opticns used with Verifier:
-polyspace-version=CC-8.2.0.5 (R2011b)
-from=scratch

-date=23/06/2011

\Logl.-{‘ Check Model }\Build }\ Configuration Management .""'\ Animation l.-'r

right-click, for example, a package or a class. From the context menu, select Stop
Polyspace Verification.

To stop an analysis on the Polyspace Server, use the Polyspace Job Monitor. See
“Monitoring an Analysis” on page 3-10.

Monitoring an Analysis

If your analysis is client-based, you can observe progress on the Log tab of the Rhapsody

editor.
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Zllpun Verification -
Argument 0: "-rtebase-dir'

Argqument l: 'C:\Polyspace\PolyapaceForCandCPP R2011b\Verifier\bkin'

Argument 2: '"-3ilent’

Argument 3: "-call-from-ide’

Argument 4: "rhapsody’

Argument 5: "-cig!’

Argument &: 'C:\Polyspace\FPolyspace Common'PolySpaceUMLLink\psdemos\CompleteSystem C++.cig’
Argument 7: '-opticns-to-overwrite!

Argument &: 'C:\Polyspace‘\Folyspace Common‘PolySpaceUMLLink\psdemos\ps_sutomatic options.txt'

<polyspace-cpp R2011k FID19320 PGID1S9320>

Polyspace werification of psdemos_uml link airbag project.
Starting at 0&/23/2011, 1&h07.

Opticons used with Verifier:

-polyspace-version=CC-8.2.0.5 (R2011b)

-from=scratch

-date=23/06/2011 7
\Logl.vi Check Model I.‘-'\Build .""'\ Configuration Management ."'\. Animation I.-'r

If your analysis is running on a Polyspace Server, in the Entire Model View, right-
click, for example, a package or a class. From the context menu, select Polyspace Job
Monitor to display the Polyspace Job Monitor. Use the Polyspace Job Monitor to manage
jobs running on a Polyspace Server.

For more information, see “Monitor Analysis”.

Viewing Polyspace Results

To view results from the last completed analysis, in the Entire Model View, right-click,
for example, a package or a class. From the context menu, select View Results. The
Polyspace environment opens, displaying the results.

For more information on Bug Finder results, see “View Results”.
Declarations for C Functions Without Arguments

By default, Rhapsody generates declarations for functions without parameters, using the
form:

void my_function()
rather than:

void my_function(void)
This can result in the following Polyspace compilation error:

Fatal error: function "my_function® has unknown prototype.
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To avoid this problem, in Rhapsody, at the project level, set the property
C_CG::Configuration: :EmptyArgumentListName to void.

Locating Faulty Code in Rhapsody Model

To identify the faulty code within your Rhapsody model using Bug Finder analysis
results:

1 In the Polyspace environment, navigate to an error, for example, a non-initialized
variable at line 102 of Airbag Control_C.

2 In the Source pane, right-click the error. From the context menu, select Back to

model.

=

AirbagContral.cpp 4 B
91 1

92

3 Xo= ¥

94

a5 AAE]

C =
a7 —
95 woid &dirbagControl C::ReadEntry() {

a3 #/#[ operation ReadEntry()

loo int new_altitude:

101

1oz ArmedEntry(hew altitude)

103 if (new altitude == v 2 packto model

104 i - .

G rourrent data = 100 | Print View - Source code AirbagControl.cpp

106 1 Search "true" in current source Ctrl+F
107 else Search "true” in all sources

108 { .

109 a *current data = 1000 Eotobins St
110 B %=  Open SourceFile

- Add Pre-Justification to Clipboard

11z AE] ) }

113 ? Create Duplicate Code Window -
< i b

Tip For the Back to model command to work, you must have your Rhapsody model
open.

The Back to model command works best when the Polyspace check is enclosed by
the tags //#[ and J#//.
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The software locates the faulty code within your Rhapsody model. Depending on the
Rhapsody configuration, the faulty code appears either in a dialog box or in the code
view.

Primitive Operation : ReadEntry in AirbagCentrol - (&

General I Description | Implementation |Arg|.|ments | Relations I Tags | Prnperties|

void ReadEntryl)

int new_altitude; s

{
#current_data = 100;

m

else
{
#current_data = 1000;

Locate oK

Note: The 64-bit version of the Polyspace product does not support the Back to
model command with the 32-bit IBM Rational Rhapsody product.

To install the 32-bit Polyspace version, from a DOS command window, run the
following command.:

DVD\Installer32bits\Windows\Diskl\InstData\VM\Polyspace.exe

Template Configuration Files

The first time you perform an analysis, the software copies a template, Polyspace
configuration file, from matlabroot/polyspace/plugin/rhapsody/etc/
template_language.psprj to the project folder. The template language .psprj
files specify the default option values for code analysis. The software renames the copy to
model_language .psprj, where:
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+ model is the name of your model
+ language is the name of the language that the model targets, that is C or C++.

You can update the template .psprj file by one of the following means:

* Editing it through the Polyspace environment

* Double-clicking the file in a Windows® Explorer window

* Replacing the template file with a copy of the .psprj file from a Rhapsody model
folder

You can then share a configuration among project members and use the configuration
with other projects.
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Install Polyspace Plugin for Simulink

4-2

By default, when you install Polyspace R2013b or later, the Simulink plugin is installed
and connected to MATLAB.

If you model on a previous version of Simulink and MATLAB, you can also connect the
Polyspace plugin on this previous version. That way you use the latest analysis software
with your preferred version of Embedded Coder® or TargetLink. The Simulink plugin
supports the four previous releases of MATLAB. For example, the R2016b version of the
Polyspace plugin supports MATLAB versions R2014b through R2016b.

If you use a cross-version of Polyspace and MATLAB, local batch analyses can only be
submitted from the Polyspace environment or using the pslinkrun command.

Note: To install a newer version of Polyspace on MATLAB R2013b or later, you must
install MATLAB without the corresponding version of Polyspace.

—r

Using an account with read/write privileges, open the older version of MATLAB.

2 Use the ver command to make sure you do not have a previous version of Polyspace
installed. See preceding note.

3 Change your Current Folder to

polyspace _root\polyspace\toolbox\pslink\pslink
polyspace root is the version of Polyspace you want to connect, for example, C:
\Program Files\MATLAB\R2016b

4 Connect the new version of Polyspace by running the command
pslinksetup("install™).

Related Examples
. “Find Defects from Simulink” on page 2-13

More About
. “Troubleshoot Back to Model”



Install Polyspace Plugin for Eclipse

Install Polyspace Plugin for Eclipse

This topic shows how to install or uninstall the Polyspace plugin for Eclipse.

Install Polyspace Plugin for Eclipse IDE

The Polyspace plugin is supported for Eclipse versions 4.3, 4.4, and 4.5. You can install
the Polyspace plugin only after you:

Install and set up Eclipse Integrated Development Environment (IDE). For more
information, see the Eclipse documentation at www.eclipse.org.

Install Java® 7. See Java documentation at www.java.com.

Uninstall any previous Polyspace plugins. For more information, see “Uninstall
Polyspace Plugin for Eclipse IDE” on page 4-5.

To install the Polyspace plugin:

1

From the Eclipse editor, select Help > Install New Software. The Install wizard
opens, displaying the Available Software page.

Click Add to open the Add Repository dialog box.

In the Name field, specify a name for your Polyspace site, for example,
Polyspace_Eclipse Plugln.

Click Local, to open the Browse for Folder dialog box.

Navigate to the MATLAB_Install\polyspace\plugin\eclipse folder. Then click
OK.

MATLAB_Install is the installation folder for the Polyspace product.

Click OK to close the Add Repository dialog box.

On the Available Software page, select Polyspace Plugin for Eclipse.
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= Install = BR[|
Available Software

Check the items that you wish to install. )l_
Work with:  Polyspace - file:/C:/Program Files/MATLAB/R2013b/polyspace/plugin/eclipse/ + Add...

Find more software by working with the "Available Software Sites” preferences.
type filter text
Name

Version
7] 100 Polyspace Plugin for Eclipse

< I

Select All Deselect All 1 item selected

Details

7] Show only the latest versions of available software Hide items that are already installed
V| Group items by category What is already installed?
Show only software applicable to target environment

V] Contact all update sites during install to find required software

@ B

@ < Bac Next > Finish Cancel

8 Click Next.
9 On the Install Details page, click Next.
10 On the Review Licenses page, review and accept the license agreement. Then click

Finish.

Once you install the plugin, in the Eclipse editor, you'll see:

+ A Polyspace menu

A Polyspace Run - Bug Finder, Results List - Bug Finder, and Result Details
view.
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File Edit Scurce Refactor Mavigate Search Project Run PolyspacT Window Help
- | B ri@ S - g [> Run Ctrl+R
& Stop
o PrD_]ECtEKp|DrEF H % Configure Project
....................................... RE|DEI:| Results

Close Results

[¥] Open Resultsin PVE
Show View r
(2) Help

Uninstall Polyspace Plugin for Eclipse IDE

Before installing a new Polyspace plugin, you must uninstall any previous Polyspace
plugins:

1 In Eclipse, select Help > About Eclipse.
2 Select Installation Details.
3 Select the Polyspace plugin and select Uninstall.

Follow the uninstall wizard to remove the Polyspace plugin. You must restart
Eclipse for changes to take effect.

Related Examples
. “Find Defects from the Eclipse Plugin” on page 2-20

More About

. “Eclipse Environment”
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Install Polyspace Add-In for Visual Studio
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This topic shows how to install or uninstall the Polyspace add-in for Visual Studio.

Install Polyspace Add-In

The Polyspace add-in is supported for Visual Studio 2010. You can install the Polyspace
add-in only after you:

+ Install Visual Studio.

*  Uninstall any previous Polyspace add-ins. For more information see “Uninstall
Polyspace Add-In for Visual Studio” on page 4-7.

To install the Polyspace add-in:

In the Visual Studio editor, select Tools > Options to open the Options dialog box.

2 Select the Environment > Add-in/Macros Security pane to display the list of
Visual Studio add-in folders.

3 Select the following check boxes:

+ Allow macros to run
+ Allow Add-in components to load
4 Click Add to open the Browse For Folder dialog box.
5 Navigate to MATLAB_Install\polyspace\plugin\msvc\VS version

* MATLAB_Install is the installation folder for the Polyspace product.

* VS _version corresponds to the version of Visual Studio that you have installed,
for example, 2010.

6 Click OK to close the Browse for Folder dialog box.
7 To close the Options dialog box, click OK.

You must restart Visual Studio for the changes to take effect. After you install the add-
in, the Visual Studio editor has:

+ A Polyspace menu
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Polyspace | Tools Test Window H
¥ Polyspace
w{ Open Job Meniter

=t

Display Polyspace Log

-\
)
=

e

Help
About

A Polyspace Log view

Uninstall Polyspace Add-In for Visual Studio

Before installing a new Polyspace add-in, you must uninstall any previous Polyspace add-

ms.

1
2

In the Visual Studio editor, select Tools > Options to open the Options dialog box.

Select the Environment > Add-in/Macros Security pane to display the list of
Visual Studio add-in folders.

Select the Polyspace add-in and select Remove.
To close the Options dialog box, click OK.

You must restart Visual Studio for the changes to take effect.

Related Examples

“Find Defects from Visual Studio” on page 2-23

More About

“Visual Studio Environment”

4-7



4

Installation and Configuration

Set Up Polyspace Metrics

4-8

In this section...

“Requirements for Polyspace Metrics” on page 4-8

“Start Polyspace Metrics Server” on page 4-9

“Configure Polyspace Preference” on page 4-10

“Configure Web Server for HTTPS” on page 4-11

“Change Web Server Port Number for Metrics Server” on page 4-13

This topic shows how to set up a Polyspace Web Metrics server to store results and
monitor software quality.

Requirements for Polyspace Metrics

You can use Polyspace Metrics to:

+ Store verification and analysis results.

+ Evaluate and monitor software quality metrics.

This table lists the requirements for Polyspace Metrics.

Task Location  |Requirements

Project configuration |Client + MATLAB

and uploads to node + Polyspace Bug Finder

server

Polyspace Metrics Network |+ MATLAB

service server + Polyspace Bug Finder
or head

node of  |Activation is not required for the Polyspace Metrics
MATLAB |service

Distributed
Computing
Server™
cluster
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Task Location  |Requirements

Downloading Client + MATLAB

complete result§ from|nodeora |. Polyspace Bug Finder

Polyspace Metrics network )
computer | Access to Polyspace Metrics server

Viewing results A network |Access to Polyspace Metrics server.

summary from computer

Polyspace Metrics

You cannot merge two different Polyspace metrics databases. However, if you install a
newer version of Polyspace on top of an older version, Polyspace Metrics automatically
updates the database to the newest version.

Start Polyspace Metrics Server

This section shows you how to start the host server for Polyspace Metrics. After you
complete this step, you must also configure the client-side settings so that the Polyspace
interface can interact with the Metrics server.

Note: If you are using a Mac as your Polyspace Metrics server, when you restart the
machine you must restart the Polyspace server daemon.

1 From the Polyspace environment, select Metrics > Metrics and Remote Server
Settings.

2 Under Polyspace Metrics Settings, specify:

* User name used to start the service — Your user name.
+ Password — Your password (Windows only).

+ Communication port — Polyspace communication port number (default 12427).
This number must be the same as the communication port number specified in
the Polyspace Interface preferences. See “Configure Polyspace Preference” on
page 4-10.

+ Folder where analysis data will be stored — Results repository for Polyspace
Metrics server.

3 If you have installed MATLAB Distributed Computing Server, clear the Start the
Polyspace mdce service without security level check box.
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For information about starting your remote cluster service, see “Set Up Server for
Metrics and Remote Analysis” on page 4-14.

4  To start the Polyspace Metrics server, click Start Daemon.

The software stores the information that you specify through the Metrics and Remote
Server Settings window in the following file:

On a Windows system, \%APPDATA%\PolyspaceRLDatas\polyspace.conf

On a Linux® system, /Zetc/Polyspace/polyspace.conf

Configure Polyspace Preference

Once you have set up your Polyspace metrics server, you must set the client-side settings
so that the Polyspace interface can communicate with your Metrics server.

1
2
3

Select Tools > Preferences.

Click the Server Configuration tab.

Under the Polyspace Metrics server configuration section:

a

If you want Polyspace to detect a server on the network that uses port 12427
(default port number), click Automatically detect the Polyspace Metrics
Server.

If you use a different port number for your Metrics server or you want to specify
the server name, click Use the following server and port. Fill in your server
name or IP address, and communication port number.

You must specify the same communication port number for all clients that use
the Polyspace Metrics service.

Under the Polyspace Metrics web interface configuration section:

a

b

Specify a Port used to download results, default is 12428. If you change this
port number, you must also change it in on the server side.

Specify which protocol to use HTTP or HTTPS. If you select HTTPS for your web
protocol, there are additional steps to set up the Metrics web server for HTTPS.

Specify a web server port number for your chosen protocol. Default port numbers
are:

+ HTTP — 8080
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+ HTTPS — 8443

If you change the port number from the default, you must configure the same
port number for the Polyspace Metrics server. See “Change Web Server Port
Number for Metrics Server” on page 4-13.

5 Under the Upload and download settings section:
+ Upload settings — After you review results from the Metrics repository, you can

upload your comments and justifications back to the repository using Metrics >
Upload to Metrics.

If you want Polyspace to automatically upload your justifications to Polyspace
Metrics when you save, select Upload justifications automatically in the
Polyspace Metrics repository....

+ Download settings — In Polyspace Metrics, when you click an item to view,
Polyspace downloads your results and opens them in the Polyspace environment.
Select where to download your Polyspace Metrics results, either:

* To the project folder, or, if a project does not exist, a default folder.

+ Ask every time where to download results.
To view Polyspace Metrics, in the address bar of your web browser, enter:
protocol://ServerName:WSPN

* protocol is http or https.
+ ServerName is the name or IP address of your Polyspace Metrics server.
+  WSPN is the web server port number, the default is 8080 or 8443.

Configure Web Server for HTTPS

By default, the data transfer between Polyspace Code Prover™ and the Polyspace
Metrics web interface is not encrypted. You can enable HTTPS for the web protocol,
which encrypts the data transfer. To set up HTTPS, you must change the server
configuration and set up a keystore for the HTTPS certificate.

Before you start the following procedure, you must complete “Start Polyspace Metrics
Server” on page 4-9 and “Configure Polyspace Preference” on page 4-10.

To configure HTTPS access to Polyspace Metrics:
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Open the Metrics and Remote Server Settings dialog box. Run the following
command:

MATLAB_Install\polyspace\bin\polyspace-server-settings.exe

Click Stop Daemon. The software stops the mdce and Polyspace Metrics services.
Now, you can make the changes required for HTTPS.

Open the SAPPDATA%\Polyspace_RLDatas\tomcat\conf\server.xml file in a
text editor. Look for the following text:

<I-
<Connector port="8443" SSLEnabled=""true'" scheme="https"
secure=""true" clientAuth="false" sslProtocol="TLS"

keystoreFile="<datadir>/_keystore" keystorePass="polyspace'/>
->

If the text is not in your server .xml file:

a Delete the entire . .\con¥\ folder.

b In the Metrics and Remote Server Settings dialog box, restart the daemon by
clicking Start Daemon.

¢ Click Stop Daemon to stop the services again so that you can finish setting up
the server for HTTPS.

The conf folder is regenerated, including the server.xml file. The file now contains
the text required to configure the HTTPS web server.

Follow the commented-out instructions in server .xml to create a keystore for the
HTTPS certificate.

In the Metrics and Remote Server Settings dialog box, to restart the Polyspace
Metrics service with the changes, click Start Daemon.

To view Polyspace Metrics, in the address bar of your web browser, enter:

https://ServerName :WSPN

ServerName is the name or IP address of the Polyspace Metrics server.

WSPN is the web server port number.



Set Up Polyspace Metrics

Change Web Server Port Number for Metrics Server

If you change or specify a non-default value for the web server port number of your
Polyspace Code Prover client, you must manually configure the same value for your
Polyspace Metrics server.

1 Select Metrics > Metrics and Remote Server Settings.

2 In the Metrics and Remote Server Settings dialog box, select Stop Daemon to stop
the Polyspace Metrics server daemon.

3 InAppData\Polyspace_RLDatas\tomcat\conf\server.xml, edit the port
attribute of the Connector element for your web server protocol.

+ For HTTP:

<Connector port="8080"/>
For HTTPS:

<Connector port="8443" SSLEnabled=""true'" scheme="https"
secure="true" clientAuth="false" sslProtocol="TLS"
keystoreFile="<datadir>/_keystore" keystorePass="polyspace'/>
4 In the Metrics and Remote Server Settings dialog box, select Start Daemon to
restart the server with the new port number.
5 On the Polyspace toolbar, select Tools > Preferences.
6 In the Server Configuration tab, change the Web server port number to match
your new value.

Related Examples

. “View Results List in Polyspace Metrics”
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Set Up Server for Metrics and Remote Analysis

In this section...

“Requirements for Remote Verification and Analysis” on page 4-15

“Start Server for Remote Verification and Polyspace Metrics” on page 4-16

“Configure Polyspace Preferences” on page 4-17

You can perform a Polyspace verification locally on your desktop or on a remote server.
This topic shows how to set up Polyspace on a server for remote batch verification.

Use these rules to determine whether to opt for remote or local verification.

Type When to Use

Remote baich Sourece files are large (more than 800 lines of code including
comments), and execution time of verification is long.

Local Source files are small, and execution time of verification is short.

With both local and remote verification, you can upload your results to the Polyspace
Metrics web interface or view them directly on your desktop application. For more
information about setting up Polyspace Metrics, see “Set Up Polyspace Metrics” on page
4-8.

The following figure shows a network that consists of a MATLAB Distributed Computing

Server cluster and a Parallel Computing Toolbox client. Polyspace Code Prover and
Polyspace Bug Finder are installed on the head node and client nodes.
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To set up remote verification:

1  Configure the head node with the Metrics and Remote Server Settings dialog box.
See, “Start Server for Remote Verification and Polyspace Metrics” on page 4-16.

2 Configure the client node through the Polyspace environment preferences. See,
“Configure Polyspace Preferences” on page 4-17.

Requirements for Remote Verification and Analysis

The following table lists the requirements for remote analysis.

Task Location  |Requirements
Project configuration |Client + MATLAB
and job submission |node .

Parallel Computing Toolbox

* Polyspace Bug Finder

MATLAB Distributed Computing Server
Polyspace Bug Finder

Remote analysis Head node
of cluster |.

For information about setting up a computer cluster, see “Install Products and Choose
Cluster Configuration”.

4-15



4 installation and Configuration

4-16

Start Server for Remote Verification and Polyspace Metrics

This procedure describes how to set up an MATLAB Distributed Computing Server
head node that is also the Polyspace Metrics server. If you do not want to set up
Polyspace Metrics, use the MATLAB Distributed Computing Server Admin Center to
set up a server for your remote verifications. See “Install Products and Choose Cluster
Configuration”.

Select Metrics > Metrics and Remote Server Settings.

2 Under Polyspace Metrics Settings, specify:

* User name used to start the service — Your user name.
+ Password — Your password (Windows only).

+  Communication port — Polyspace communication port number (default 12427).
This number must be the same as the communication port number specified on
the Polyspace Preferences > Server Configuration tab.

+ Folder where analysis data will be stored — Results repository for Polyspace
Metrics server.

3 To configure the Polyspace Metrics server as the MATLAB Distributed Computing
Server head node, select Start the Polyspace mdce service without security
level.

The mdce service, which is required to manage the MJS, runs on the MJS host
computer with security level 0. At level 0, jobs are associated with the default user
name of the user. A login or password is not required to manage and see these jobs.

If you want to require authentication to use the remote server, use the MATLAB
Distributed Computing Server Admin Center. For more information about setting
up security levels, see “Set MJS Cluster Security”.

Under Start the Polyspace mdce service without security level, you see the
following additional options:

* Mdce service port — 27350.

This option specifies the port on which you connect to the MdJS server. If you
change this number, you must change it on both the server and client side. See
“Verify Network Communications for Cluster Discovery”.

+ Use secure communication — Not selected by default
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By default, communication between the job manager and workers is not
encrypted. To make the connection more secure, you can select this option to
encrypt communications. Alternatively, you can increase the security level of your
MJS server. See “Set MJS Cluster Security”.

4  To start the Polyspace Metrics server and mdce service, click Start Daemon.

The software stores the information that you specify through the Metrics and Remote
Server Settings dialog box in the following file:

On a Windows system, %APPDATA%\PolyspaceRLDatas\polyspace.conf
On a Linux system, Zetc/Polyspace/polyspace.conf

Configure Polyspace Preferences

1
2
3

Select Tools > Preferences.

Click the Server Configuration tab.

Under MATLAB Distributed Computing Server cluster configuration:

a

b

In the Job scheduler host name field, specify the computer for the head node
of the cluster. This computer hosts the MATLAB job scheduler (MJS).

Due to network setting, the job manager may be unable to connect back to your
local computer. If this is the case, enter the IP address of the client computer in
the Localhost IP address field.

To retrieve your IP address:

Windows

i  Open Control Panel > Network and Sharing Center.
il Select your active network.

ili  In the Status window, click Details. Your IP address is listed under
IPv4 address.

Linux — Run the ifconfig command and find the inet addr
corresponding to your network connection.

Mac — Open System Preferences > Network.

If required, you can configure additional options for the MJS host through the
MATLAB Distributed Computing Server Admin Center. See “Configure for an MJS”.
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4 Under the Polyspace Metrics server configuration section:

a

If you want Polyspace to detect a server on the network that uses port 12427
(default port number), click Automatically detect the Polyspace Metrics
Server.

If you use a different port number for your Metrics server or you want to specify
the server name, click Use the following server and port. Fill in your server
name or [P address, and communication port number.

You must specify the same communication port number for all clients that use
the Polyspace Metrics service.

5 Under the Polyspace Metrics web interface configuration section:

a

Specify a Port used to download results, default is 12428. If you change this
port number, you must also change it in on the server side.

Specify which protocol to use HTTP or HTTPS. If you select HTTPS for your web
protocol, there are additional steps to set up the Metrics web server for HTTPS.

Specify a web server port number for your chosen protocol. Default port numbers
are:

+ HTTP — 8080

+ HTTPS — 8443

If you change the port number from the default, you must configure the same

port number for the Polyspace Metrics server. See “Change Web Server Port
Number for Metrics Server” on page 4-13.

6 Under the Upload and download settings section:

Upload settings — After you review results from the Metrics repository, you can
upload your comments and justifications back to the repository using Metrics >
Upload to Metrics.

If you want Polyspace to automatically upload your justifications to Polyspace
Metrics when you save, select Upload justifications automatically in the
Polyspace Metrics repository.

Download settings — In Polyspace Metrics, when you click an item to view,
Polyspace downloads your results and opens them in the Polyspace environment.
Select where to download your Polyspace Metrics results, either:
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To the project folder, or, if a project does not exist, a default folder.
Ask every time where to download results.

Related Examples

“Set Up Polyspace Metrics” on page 4-8
. “Run Remote Batch Analysis”

“Job Manager Cannot Write to Database”
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Differences Between Polyspace Bug Finder and Polyspace Code
Prover Analysis

Polyspace Bug Finder and Polyspace Code Prover detect run-time errors through static
analysis. Though the products have a similar user interface and the mathematics
underlying the analysis can sometimes be the same, the goals of the two products are
different.

Bug Finder quickly analyzes your code and detects many types of defects. Code Prover
checks every operation in your code for a set of possible run-time errors and tries to prove

the absence of the error for all execution paths’. For instance, for every division in your
code, a Code Prover analysis tries to prove that the denominator cannot be zero. Bug
Finder does not perform such exhaustive verification. For instance, Bug Finder also
checks for a division by zero error, but it might not find all operations that can cause the
error.

The two products involve differences in setup, analysis and results review, because

of this difference in objectives. In the following sections, we highlight the primary
differences between a Bug Finder and a Code Prover analysis (also known as
verification). Depending on your requirements, you can incorporate one or both kinds of
analyses at appropriate points in your software development life cycle.

In this section...

“Faster Analysis with Bug Finder” on page 5-3

“More Exhaustive Verification with Code Prover” on page 5-3

“More Specific Defect Types with Bug Finder” on page 5-4

“Easier Setup Process with Bug Finder” on page 5-4

“Fewer Runs for Clean Code with Bug Finder” on page 5-5

“Results in Real Time with Bug Finder” on page 5-5

“More Rigorous Data and Control Flow Analysis with Code Prover” on page 5-6
“Few False Positives with Bug Finder” on page 5-7

“Zero False Negatives with Code Prover” on page 5-8

1. For each operation in your code, Code Prover considers all execution paths leading to the operation that
do not have a previous error. If an execution path contains an error prior to the operation, Code Prover
does not consider it. See “Verification Following Red and Orange Checks” in Code Prover documentation.
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In this section...
“Workflow Using Both Bug Finder and Code Prover” on page 5-8

Faster Analysis with Bug Finder

How much faster the Bug Finder analysis is depends on the size of the application. The
Bug Finder analysis time increases linearly with the size of the application. The Code
Prover verification time increases at a rate faster than linear.

One possible workflow is to run Code Prover to analyze modules or libraries for
robustness against certain errors and run Bug Finder at integration stage. Bug Finder
analysis on large code bases can be completed in a much shorter time, and also find
integration defects such as Declaration mismatch and Data race.

More Exhaustive Verification with Code Prover
Code Prover tries to prove the absence of:

* Division by Zero error on every division or modulus operation
* Out of Bounds Array Index error on every array access
* Non-initialized Variable error on every variable read

+  Overflow error on every operation that can overflow
and so on.
For each operation:

+ If Code Prover can prove the absence of the error for all execution paths, it highlights
the operation in green.

+ If Code Prover can prove the presence of a definite error for all execution paths, it
highlights the operation in red.

+ If Code Prover cannot prove the absence of an error or presence of a definite error,
it highlights the operation in orange, indicating that you must review the operation
carefully, through visual inspection or testing.

Bug Finder does not aim for exhaustive analysis. It tries to detect as many bugs as
possible and reduce false positives. For critical software components, running a bug
finding tool is not sufficient because despite fixing all defects found in the analysis, you
can still have errors during code execution. After running Code Prover on your code and
addressing the issues found, you can expect the quality of your code to be much higher.
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More Specific Defect Types with Bug Finder

Code Prover checks for types of run-time errors where it is possible to mathematically
prove the absence of the error. In addition to detecting errors whose absence can be
mathematically proven, Bug Finder also detects other defects.

For instance, the statement 1 F(a=b) is semantically correct according to the C
language standard, but often indicates an unintended assignment. Bug Finder detects
such unintended operations. Although Code Prover does not detect such unintended
operations, it can detect if an unintended operation causes other run-time errors.

Examples of defects detected by Bug Finder but not by Code Prover include good practice
defects, resource management defects, some programming defects, security defects, and
defects in C++ object oriented design.

For more information, see:

+ “Defects”: List of defects that Bug Finder can detect.

+ “Run-Time Checks”: List of run-time errors that Code Prover can detect.

Easier Setup Process with Bug Finder

Even if your code builds successfully in your compilation toolchain, it can fail in the
compilation phase of a Code Prover verification. The strict compilation in Code Prover is
related to its ability to prove the absence of certain run-time errors.

* Code Prover strictly follows the ANSI® C99 Standard, unless you explicitly use
analysis options that emulate your compiler.

To allow deviations from the ANSI C99 Standard, you must use the “Target &
Compiler” options. If you create a Polyspace project from your build system, the
options are automatically set.

+  Code Prover does not allow linking errors that common compilers can permit.
Though your compiler permits linking errors such as mismatch in function signature

between compilation units, to avoid unexpected behavior at run time, you must fix the
errors.

For more information, see “Troubleshoot Compilation and Linking Errors” in Code Prover
documentation.
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Bug Finder is less strict about certain compilation errors. Linking errors, such as
mismatch in function signature between different compilation units, can stop a Code
Prover verification but not a Bug Finder analysis. Therefore, you can run a Bug Finder
analysis with less setup effort. In Bug Finder, linking errors are often reported as a
defect after the analysis is complete.

Fewer Runs for Clean Code with Bug Finder

To guarantee absence of certain run-time errors, Code Prover follows strict rules once it

detects a run-time error in an operation. Once a run-time error occurs, the state of your

program is ill-defined and Code Prover cannot prove the absence of errors in subsequent
code. Therefore:

+ If Code Prover proves a definite error and displays a red check, it does not verify the
remaining code in the same block.

Exceptions include checks such as Overflow, where the analysis continues with the
result of overflow either truncated or wrapped around.

+ If Code Prover suspects the presence of an error and displays an orange check, it
eliminates the path containing the error from consideration. For instance, if Code
Prover detects a Division by Zero error in the operation 1/Xx, in the subsequent
operation on X in that block, X cannot be zero.

+ If Code Prover detects that a code block is unreachable and displays a gray check, it
does not detect errors in that block.

For more information, see “Verification Following Red and Orange Checks” in Code
Prover documentation.

Therefore, once you fix red and gray checks and rerun verification, you can find more
issues. You need to run verification several times and fix issues each time for completely
clean code. The situation is similar to dynamic testing. In dynamic testing, once you fix a
failure at a certain point in the code, you can uncover a new failure in subsequent code.

Bug Finder does not stop the entire analysis in a block after it finds a defect in that
block. Even with Bug Finder, you might have to run analysis several times to obtain
completely clean code. However, the number of runs required is fewer than Code Prover.

Results in Real Time with Bug Finder

Bug Finder shows some analysis results while the analysis is still running. You do not
have to wait until the end of the analysis to review the results.
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Code Prover shows results only after the end of the verification. Once Bug Finder finds
a defect, it can display the defect. Code Prover has to prove the absence of errors on all
execution paths. Therefore, it cannot display results during analysis.

More Rigorous Data and Control Flow Analysis with Code Prover

For each operation in your code, Code Prover provides:

* Tooltips showing the range of values of each variable in the operation.

For a pointer, the tooltips show the variable that the pointer points to, along with the
variable values.

* Graphical representation of the function call sequence that leads to the operation.

By using this range information and call graph, you can easily navigate the function
call hierarchy and understand how a variable acquires values that lead to an error.
For instance, for an Out of Bounds Array Index error, you can find where the index
variable is first assigned values that lead to the error.

When reviewing a result in Bug Finder, you also have supporting information to
understand the root cause of a defect. For instance, you have a traceback from where Bug
Finder found a defect to its root cause. However, in Code Prover, you have more complete
information, because the information helps you understand all execution paths in your
code.
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static void Sguare Root conv(double alpha, flocat* beta pt)

/* Perform arithmetic conversion of alpha to beta */

beta pt = (float) {{1.5 + cos{alpha)}) / 5.0)7

Dereference of parameter 'beta_pt' (pointer to float 32, size: 32 bits):
Pointer is not null.
Points to 4 bytes at offset (0 in buffer of 4 bytes, so is within bounds (if memory is allocated).

tati ] _ . .

j "1 Pointer may point to variable or field of variable:
d 'beta’; local to function 'Square Roof'.
_| Assignment to dereference of parameter 'beta_pt' (float 32): [0.1 .. 0.5]
:_ Press "F2" for foous
Square Root_conv(alpha, sbeta):

Jamma = {:'lcat:lgqrt {beta - 0.75); /* always sgrt{negative number) */

}

Data Flow Analysis in Code Prover
main.c single_file_analysis.c single_file_analysis.c single_file_analysis.c
main generic_validation reset_temperature OBAI

Control Flow Analysis in Code Prover

Few False Positives with Bug Finder

Bug Finder aims for few false positives, that is, results that you are not likely to fix. By
default, you are shown only the defects that are likely to be most meaningful for you.

Bug Finder also assigns an attribute called impact to the defect types based on the
criticality of the defect and the rate of false positives. You can choose to analyze your code
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only for high-impact defects. You can also enable or disable a defect that you do not want
to review®.

Zero False Negatives with Code Prover

Code Prover aims for an exhaustive analysis. The software checks every operation that
can trigger specific types of error. If a code operation is green, it means that the operation
cannot cause those run-time errors that the software checked for’. In this way, the
software aims for zero false negatives.

If the software cannot prove the absence of an error, it highlights the suspect operation in
red or orange and requires you to review the operation.

Workflow Using Both Bug Finder and Code Prover

If you have both the Bug Finder and Code Prover softwares, based on the above
differences, you can deploy the two products appropriately in your software development
workflow. For instance:

+ All developers in your organization can run Bug Finder on newly developed code.
For maintaining standards across your organization, you can deploy a common
configuration that looks only for specific defect types.

Code Prover can be deployed for longer time periods. For instance, you can run the
product on remote servers once or twice a month on your entire code base.

* You can run Code Prover only on critical parts of your software, while running Bug
Finder on your entire code base.

* You can run Code Prover on modules of code at the unit testing level, and run Bug
Finder when integrating the modules.

Depending on the nature of your software development workflow and available resources,
there are many other ways you can incorporate the two kinds of analysis. There are two
important considerations if you are running both Bug Finder and Code Prover on the
same code.

*  Both products can detect violations of coding rules such as MISRA C rules and JSF® C

++ rules.
2. You can also disable certain Code Prover defects related to non-initialization.
3. The Code Prover result holds only if you execute your code under the same conditions that you supplied

to Code Prover through the analysis options.
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However, if you want to detect MISRA C:2012 coding rule violations alone, use Bug
Finder. Bug Finder supports all the MISRA C:2012 coding rules. Code Prover does not
support a few rules.

+ If you set up a project in the Bug Finder user interface, you can open the project
directly in the Code Prover user interface. The following set of options from your Bug
Finder configuration are retained in Code Prover:

“Target & Compiler”

“Macros”

“Environment Settings”

“Inputs & Stubbing”

“Multitasking”

“Coding Rules & Code Metrics”

“Reporting”, except Report template (-report-template)
“Distributed Computing”

You might have to change more of the default options when you run the Code Prover
verification because Code Prover is stricter about compilation and linking errors.
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